Competences mises en oeuvre pour cette activite professionnelle








télécharger 218.51 Kb.
titreCompetences mises en oeuvre pour cette activite professionnelle
date de publication12.07.2017
taille218.51 Kb.
typeDocumentos
ar.21-bal.com > loi > Documentos



BTS SIO

Services Informatiques aux Organisations



Option

SISR

Session

2015



Benjamin FRULEUX


Activité professionnelle N°

24



Nature de l’activité

GESTION DE PARC INFORMATIQUE


Objectifs

Mise en place de HSRP, check up du réseau & installation d’OCS/GLPI ainsi que MDT/WAIK & TSE



COMPETENCES MISES EN OEUVRE POUR CETTE ACTIVITE PROFESSIONNELLE

A1.1.1

Analyse du cahier des charges d’un service à produire

A1.2.2

Rédaction des spécifications techniques de la solution retenue

A1.3.4

Déploiement d’un service

A4.1.9

Rédaction d’une documentation technique

A5.1.4

Etude des propositions de contrat de service

A5.1.5

Evaluation d’un élément de configuration ou d’une configuration

A5.1.6

Evaluation d’un investissement informatique

A5.2.4

Etude d’une technologie, d’un composant, d’un outil ou d’une méthode



DEROULEMENT DE L'ACTIVITE

La configuration du réseau M2L est la suivante :
- Chaque Vlan implémentés voient son Adresse de Réseau s’incrémentée de 1, au niveau de son 3ème octet.
Exemple : Vlan 10 : TENNIS = 172.16.10.0

Vlan 11 : ATHLE = 172.16.11.0
- Il est nécessaire de mettre en place un protocole de communication sécurisé (SECURE SHELL) SSH, qui crypte les trames TCP, particulièrement l’authentification. Ici le domaine sera celui de la M2L.


- Les postes Clients (Ligues) ont une haute disponibilité de service, grave au Spanning-Tree (redondance).

CLI :
spanning-tree mode pvst

spanning-tree vlan 12 priority 20480

spanning-tree vlan 1,10-11,99 priority 24576

vlan 10

name TENNIS

vlan 11

name ATHLE

vlan 12

name BASKET

vlan 99

name GESTION

interface FastEthernet0/1

switchport mode trunk

switchport nonegotiate

interface FastEthernet0/2

channel-group 1 mode active

switchport mode trunk

interface FastEthernet0/3

channel-group 1 mode active

switchport mode trunk

interface FastEthernet0/4

channel-group 2 mode active

switchport mode trunk

interface FastEthernet0/5

channel-group 2 mode active

switchport mode trunk
- La DMZ (Demilitarized Zone) est une zone accessible depuis le réseau interne, mais aussi depuis l’internet.

ROUTER M2L
ACL :

Access-list 101 permit tcp any host 192.168.0.12 eq www

Access-list 101 permit tcp any host 192.168.0.12 eq 443

Access-list 101 permit tcp any host 192.168.0.12 eq ftp

Access-list 101 permit tcp any host 192.168.0.13 eq www

Access-list 101 permit tcp host 192.168.0.12 any eq www

Access-list 101 permit tcp host 192.168.0.12 any eq 443

Access-list 101 permit tcp host 192.168.0.13 any eq www

Access-list 101 permit tcp any 0.0.0.0 255.255.0.0 established

ROUTER HSRP PRIMAIRE :

Routes :

ip nat inside source list 11 interface FastEthernet0/1 overload

ip nat inside source static tcp 192.168.0.13 80 221.87.149.1 80

ip nat inside source static tcp 192.168.0.13 443 221.87.149.1 443

ip nat inside source static tcp 192.168.0.12 21 221.87.149.1 21

ip nat inside source static tcp 192.168.0.11 22 221.87.149.1 22
- Les utilisateurs de la M2L ont accès à Internet, mais pas l’inverse.
ROUTER HSRP PRIMAIRE
ACL :

access-list 11 permit 172.16.0.0 0.0.31.255

access-list 101 permit tcp any 0.0.0.0 255.255.0.0 established

Routes :

ip route 172.16.2.0 255.255.255.192 10.0.0.1

ip route 172.16.3.0 255.255.255.192 10.0.0.1

ip route 0.0.0.0 0.0.0.0 FastEthernet0/1

ip route 172.16.10.0 255.255.255.192 10.0.0.1

ip route 172.16.11.0 255.255.255.192 10.0.0.1

ip route 172.16.12.0 255.255.255.192 10.0.0.1

- Seul les postes du vlan Informatique VLAN 2, peuvent avoir pinger les postes de la M2L.
ACL :

Access-list 101 permit icmp 172.16.2.0 0.0.0.63 any

Il faut préciser que dans une Acl, est spécifié, toutes configurations par rapport au même domaine seront interdites. Par exemple, ici, nous autorisons tous les postes du VLAN 2, à avoir accès à n’importe quel autre poste, donc aucun autre poste ne pourra plus le faire.

- Afin de pouvoir avoir plusieurs VLAN sur un port, il a été nécessaire de pratiquer deux encapsulations de VLAN
ROUTEUR DES LIGUES : VLAN 10 : TENNIS

VLAN 11 : BASKET VLAN 12 : ATHLÉ

interface FastEthernet0/1.10

encapsulation dot1Q 10

ip address 172.16.10.62 255.255.255.192

ip helper-address 172.16.2.60

ip helper-address 172.16.2.61

interface FastEthernet0/1.11

encapsulation dot1Q 11

ip address 172.16.11.62 255.255.255.192

ip helper-address 172.16.2.60

ip helper-address 172.16.2.61

interface FastEthernet0/1.12

encapsulation dot1Q 12

ip address 172.16.12.62 255.255.255.192

ip helper-address 172.16.2.60

ip helper-address 172.16.2.61
ROUTEUR DE LA M2L : VLAN 2 : INFORMATIQUE

interface Ethernet1/1.2 VLAN 3 : ADMINISTRATION

encapsulation dot1Q 2

ip address 172.16.2.62 255.255.255.192

ip helper-address 172.16.2.60

ip helper-address 172.16.2.61

!

interface Ethernet1/1.3

encapsulation dot1Q 3

ip address 172.16.3.62 255.255.255.192

ip helper-address 172.16.2.60

ip helper-address 172.16.2.61
Et, finalement pour avoir un adressage ip dynamique via les 2 DHCP, nous avons dû placer des relais DHCP sur les routeurs, pour que les postes présent dans ton les ligues aient une adresse IP.
DHCP :



DHCP 2 :


Le petit plus TREENET OMEGA :
TREENET OMEGA, afin que la M2L puisse toujours avoir une connexion internet constante via le HSRP (haute disponibilité de connexion a internet) via deux routeurs, un primaire et un secondaire (redondant).
ROUTEUR HSRP PRIMAIRE :
interface FastEthernet0/0

ip address 10.0.0.2 255.255.255.248

ip nat inside

duplex auto

speed auto

standby version 2

standby 10 ip 10.0.0.6

standby 10 priority 215

standby 10 track FastEthernet0/1

standby preempt

ROUTEUR HSRP SECONDAIRE :

interface FastEthernet0/0

ip address 10.0.0.2 255.255.255.248

ip nat inside

duplex auto

speed auto

standby version 2

standby 10 ip 10.0.0.6

standby 10 preempt

Nota Bene : La fonction HSRP fonctionne avec des priorités que l’on affecte par un nombre : Exemple ROUTEUR HSRP PRIMAIRE 110
Si, nous affectons au Routeur SECONDAIRE la priorité 105, il sera redondant au routeur PRIMAIRE par décrémentation, si le routeur n’ai pas accessible, il lui est automatiquement enlevé 10 de valeur prioritaire : 10 – 110 = 100, et comme le routeur secondaire a une valeur de 105 : 105 >100, alors le routeur secondaire devient le routeur par où passe la connexion.

DHCP & DHCP2 :

Le serveur Dhcp permet une distribution d’adresse ip, pour un système automatisé, le Dhcp2 quant à lui permet une haut disponibilité des services, et donc une pérennité de l’adressage ip.
ACTIVE DIRECTORY :

Permet une administration simplifiée des Ligues de la M2L. L'objectif principal d'Active Directory est de fournir des services centralisés d'identification et d'authentification à un réseau d'ordinateurs utilisant le système Windows.
Il permet également l'attribution et l'application de stratégies, la distribution de logiciels, et l'installation de mises à jour critiques par les administrateurs.
Active Directory répertorie les éléments d'un réseau administré tels que les comptes des utilisateurs, les serveurs, les postes de travail, les dossiers partagés, les imprimantes, etc.
TSE/WDS :

TSE (Terminal Serveur) permet aux utilisateurs de la M2L un accès à des logiciels ou applications sur un poste distant : ici ce sera un serveur TSE, avec application WEB.

WDS (Windows Deployment Service) permet d’installer un système d’exploitation sur des postes clients via un démarrage sur le réseau (Boot PXE).
Avantage :

- Rapidité (environ 10 minutes pour une image complète d'un poste),

- Déploiement en masse,

- Possibilité d'intégrer des modifications en cours de route,

- ISO-Bootimages pour ordinateur sans PXE, qui se font de plus en rare de nos jours.

- Les images sont indépendantes du matériel)
Inconvénients :

- Le poste client a besoin de plus de 256 Mo de RAM, ce qui est plus que courant de nos jours….

- Le temps entre le moment du démarrage et le chargement de l'image est d'environ 2 ou 3 minutes.

MDT :
Microsoft Deployment Toolkit peut aider à construire une source d'installation automatisée pour le déploiement de Windows 7, Windows 8, à partir d'une seule machine ou un outil de distribution de serveur central, tels que les services de

déploiement Windows (WDS) ou System Center Configuration Manager (SCCM). les pilotes de périphériques, mises à jour et les logiciels Windows peuvent être inclus dans la construction.

Ce qui permet d’avoir une image installée sur les postes le plus adapté aux besoins des utilisateurs, et mis en adéquation avec WDS, permet d’avoir un service automatisé, et pertinent quant à la demande de la M2L
OCS/GLPI :

Open Computer and Software Inventory (OCS Inventory) nous permet d’avoir un inventaire du matériel et de leur configuration de manière automatique, mis en place dans le réseau de la M2L et d’y avoir accès depuis une interface Web.

GLPI (Gestionnaire Libre de Parc Informatique), est un logiciel GPL (General Public License). GLPI est une application web permettant la gestion de parc informatique et de gestion des services d'assistances, afin d’avoir une assistance (HELPDESK), avec une ouverture de ticket via Web, email ou même téléphone.
NAGIOS :

Nagios est une application permettant la surveillance système et réseau. Elle surveille les utilisateurs et services spécifiés, alertant lorsque les systèmes ont des dysfonctionnements et quand ils repassent en fonctionnement normal. C'est un logiciel libre sous licence GPL (General Public License).
ADMINISTRATION SYSTÈME :

Simulation avec la virtualisation (VMware Workstation & Virtual Box)

TSE

Le TSE, comprenez Terminal Server Edition est une application de type 'main-frame' de Microsoft qui réside dans la mise en place d'un serveur applicatif pour terminaux.
Les terminaux peuvent être des PC (Windows), des PC (Unix/Linux), des Macintosh, de simples navigateurs Internet ou des postes terminaux appelés aussi clients légers.
Les applications et les données sont uniquement stockées et exécutées sur le serveur TSE. Le télétravail, en plein essor, s'appuie essentiellement sur ce type de technologie.

D'ailleurs, cette technologie séduit de plus en plus d'entreprises car elle permet de regrouper les services informatiques en un seul point et de réduire les coûts d'infrastructure.
Ce serveur, suffisamment dimensionné, dispose de toutes les applications à mettre en œuvre pour les utilisateurs des sites distants : par exemple, une gestion commerciale, un logiciel de comptabilité etc...

Le serveur TSE agit alors comme une sorte de superordinateur qui accepte X utilisateurs simultanés !
Les origines du Terminal Server

Le concept de centraliser les données d'une entreprise ne date pas d'hier. Dans les années 1960-1970, l'informatique était souvent réservée à un seul service d'une entreprise. Elle était centralisée, basée sur des mainframes auxquels étaient reliés des terminaux passifs, appelés "postes de saisie".
Cette architecture centralisée nécessitait un investissement dont le coût était non négligeable il est vrai, mais elle était très fiable. Ce type d'architecture homogène et solide durait entre 8 et plus de 20 ans !
L'avènement des réseaux locaux et d'Internet a consacré les modes de fonctionnement hétérogènes : les utilisateurs ont été équipés de postes, d'applications et de fonctionnalités différentes.
Dans ce type d'architecture, les failles de sécurité sont fréquentes, l'administration du réseau compliquée et les connexions à distance peu sûres. S'est alors posé la question de savoir comment concilier sécurité du système d'information, fonctionnalité, disponibilité et budget maîtrisé. Le problème est d'autant plus délicat lorsque nous évoquons une société avec des sites distants et/ou des télétravailleurs...
Le système TS ou RDS s'est alors imposé comme une évidence pour beaucoup d'entreprises. Saviez-vous que les responsables informatiques des entreprises figurant au classement Fortune 1000, optaient pour la centralisation de leur système informatique ? Plutôt que d'équiper chacun de leurs sites distants, ces entreprises performantes ont choisi de centraliser leurs serveurs dans des datacenters ou infocentres, afin de réduire intelligemment les coûts d'exploitation des sites distants.

Un système informatique centralisé est plus simple à administrer et à maintenir, ce qui représente un atout considérable en termes de sécurité et d'optimisation des coûts.

Mode de fonctionnement

Terminal Server ou Remote Desktop Services, une fois activé sur un serveur Windows 2003 ou Windows 2008, permet aux utilisateurs de se connecter à un bureau virtuel que l'on appelle une session.
Contrairement à une architecture classique, où les différentes applications d'un utilisateur sont exécutées sur son poste local, dans le système RDS, elles sont exécutées sur le serveur. Ainsi, seule l'image du bureau virtuel de l'utilisateur est transmise via le réseau.


Du moment où les données des utilisateurs de toute l'entreprise sont centralisées sur un serveur, cela permet l'accès à distance simple et sûr depuis n'importe quel poste, appelé client distant. Le client distant peut fonctionner sous Windows, Mac OS et les distributions de Linux graphiques. Pour accéder au serveur, le client distant utilise un protocole crée par Microsoft appelé RDP pour Remote Desktop Protocol.
Ce protocole utilise une connexion TCP/IP et s'avère très efficace autant sur un LAN (Local Area Network) qu'au travers d'un WAN (Wide Area Network). Avec Remote Desktop Services, Windows Server utilise un noyau système spécifique pour autoriser de multiples utilisateurs à se connecter simultanément au même serveur et à utiliser les mêmes applications, même si chacun d'eux utilise sa propre session.

Présentation d’OCS & GLPI

La M2L est de plus en plus importante et une bonne gestion de son parc informatique est devenue primordiale. Dans ce but, nous allons y mettre en place un système de gestion de parc et d’incidents. Nous avons sélectionné des utilitaires OpenSource afin de réduire au maximum les coûts.
Pour cela, nous utiliserons deux outils distinct, mais pouvant être relié ensemble, grâce à un module complémentaire :

- GLPI : Gestion Libre de Parc Informatique

o Permet la gestion d’incidents afin de répertorier les problèmes informatique et de les traiter en fonction de leur priorité.

o Permet la gestion du parc informatique (périphériques, numéro de série, système d’exploitation, licences …)

o Gestion de GLPI via une interface Web
- OCS Inventory NG : Open Computers and Software Inventory Next Generation

o Permet la gestion de parc informatique de façon automatisée (périphériques, numéro de série, système d’exploitation, licences …)

o Gestion d’OCS Inventory NG via une interface Web
Une fois OCS lié à GLPI, le parc informatique présent dans OCS est importé dans GLPI, permettant à GLPI de pouvoir gérer son parc informatique de manière automatique alors que cette fonction n’est pas disponible de base.

L’installation de ce système est peu couteuse étant donné que les utilitaires et le système d’exploitation prévu pour la mise en place du système sont tous OpenSource.

Matérielle nécessaire pour la mise en place du système :

- Un serveur Debian

- Une machine cliente pour les tests
I) GLPI


  1. Installation de GLPI


















ADMINISTRATION DU SYSTÈME II
La M2L possède un serveur de déploiement d’images basé sur WDS qui a été mis en place par son Administrateur. Il souhaite à présent y ajouter des outils permet-tant d’une part d’ajouter des images, des logiciels, des pilotes et d’autre part d’automatiser au maximum les déploiements. Les solutions retenues consiste-raient à mettre en oeuvre des outils MDT et WAIK.
Qu’est-ce que les outils MDT et WAIK ?
Microsoft Deployment Toolkit (MDT) est un outil gratuit de Windows qui vient en complément de WDS. Il permet la personnalisation des Images comme par exemple y insérer des applications, des pilotes ainsi que des séquences de tache, etc… Il permet également le déploiement de ces images personnalisées.

Il existe différentes versions, de MDT, qui permettent de déployer, d’après

Microsoft, différents Système d’exploitation.


Le Kit d’installation automatisée (WAIK) est un ensemble d'outils et de

documentation qui prend en charge la configuration et le déploiement des systèmes d'exploitation Windows®. Il est nécessaire au bon fonctionnement de MDT. Windows AIK vous permet d'automatiser les installations de Windows, de capturer des images Windows avec ImageX, de configurer et de modifier des images à l'aide de l'outil « Gestion et maintenance des images de déploiement » (DISM), de créer des images Windows PE ainsi que d'effectuer la migration de profils d'utilisateurs et de données avec l'Outil de migration utilisateur (USMT). Windows AIK inclut également l'Outil VAMT (Volume Activation Management Tool), qui permet aux professionnels de l'informatique d'automatiser et de gérer de manière centralisée le processus d'activation de volume à l'aide d'une Clé d'activation multiple (MAK).
Nous proposons à la M2L d’utiliser la plus part du temps MDT qui est un outil graphique. En effet, WAIK étant majoritairement en ligne de commande cela serait moins intuitif.
MDT est vraiment très complet pour vos besoins. L’un de ses plus grands avantages est la personnalisation des OS à déployer. De plus, avec MDT vous aurez accès à deux types de déploiement qui répondront parfaitement aux différents scénarios.
Les Deux types de déploiement via MDT :

-

Lite Touch Intervention : Méthode de déploiement permettant de déployer

vos OS et applications. C’est la solution idéale pour les petites et moyennes structures. Le déploiement LTI peut être réalisé avec ou quasiment sans assistance humaine.


























Mise en place d’une DMZ






CONCLUSION

La mise en place d’une tel infrastructure dans la M2L permet une meilleure automatisation de déploiement, des outils permettant l’échange de données DMZ par serveur ftp ou Web, deux routeur HSRP pour la redondance de lien vers internet, ROUTAGE OSPF, pour des dynamiques, des switch en spanning-tree pour une haute disponibilité, ainsi que OCS/GLPI pour une gestion des incidents, ce qui fait que la M2L un réseau presque complet.





EVOLUTION POSSIBLE

La mise ne place de réseau sans fil, d’un serveur d’authentification pour parfaire le réseau de la M2L.

similaire:

Competences mises en oeuvre pour cette activite professionnelle iconCompetences mises en oeuvre pour cette activite professionnelle

Competences mises en oeuvre pour cette activite professionnelle iconFormation Principalement autodidacte. 1998 deug mia à l’Université...

Competences mises en oeuvre pour cette activite professionnelle iconCompétences mises en œuvre dans différents projets

Competences mises en oeuvre pour cette activite professionnelle iconArismore accompagne mma pour la montée en compétences des Architectes du si
«L, au-delà de la montée en compétences des architectes, est d’inscrire cette démarche dans la durée auprès des parties prenantes...

Competences mises en oeuvre pour cette activite professionnelle iconAdresse : 1 Boulevard Trimolet 21000 Dijon
«Bilan pédagogique et financier» doit permettre à l’administration de retracer l’ensemble de l’activité pédagogique du dispensateur...

Competences mises en oeuvre pour cette activite professionnelle iconAdresse : 38 Bis Rue de l'Alma 92400 Courbevoie
«Bilan pédagogique et financier» doit permettre à l’administration de retracer l’ensemble de l’activité pédagogique du dispensateur...

Competences mises en oeuvre pour cette activite professionnelle iconAdresse : 90 Chemin des Fins 74000 Annecy
«Bilan pédagogique et financier» doit permettre à l’administration de retracer l’ensemble de l’activité pédagogique du dispensateur...

Competences mises en oeuvre pour cette activite professionnelle iconAdresse : Patinoire Meriadeck 95 Cours du Maréchal Juin 33000 Bordeaux
«Bilan pédagogique et financier» doit permettre à l’administration de retracer l’ensemble de l’activité pédagogique du dispensateur...

Competences mises en oeuvre pour cette activite professionnelle iconAdresse : Palais de la Glace 2483 Chemin des Amandiers 84000 Avignon
«Bilan pédagogique et financier» doit permettre à l’administration de retracer l’ensemble de l’activité pédagogique du dispensateur...

Competences mises en oeuvre pour cette activite professionnelle iconAdresse Patinoire du haras 15 allée du haras 49100 Angers
«Bilan pédagogique et financier» doit permettre à l’administration de retracer l’ensemble de l’activité pédagogique du dispensateur...








Tous droits réservés. Copyright © 2016
contacts
ar.21-bal.com